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Exercise 1 - Creating an Epic
Estimated Time: 10 minutes
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Log into Jira.

. At the top left of the main navigation bar, click the waffle icon.

Under the Switch to column, locate the Jira Software icon.

From the drop-down list, select the dish-wireless-training option.

. From the Projects drop-down list, select the View all projects option.

a. Note: The instance may prepopulate to the Projects screen as soon as
you select the Wireless Training option.

Select the Training project.
At the top of the screen, click the blue Create button.
The Create Issue screen displays.

In the Project drop-down field, ensure the Atlassian Training (JC101) option
prepopulates.

In the Issue Type field, select the Epic option.

a. Note: This screen automatically defaults to creating a Story. If you’re
creating an Epic, double-check the correct issue type is selected.

In the Summary field, input an appropriate summary for the work you’re
adding to the project.

In the Description field, input the applicable description for the Epic.
In the Assignee field, select yourselffrom the drop-down list.
In the Target Start field, enter the planned date for work to start on the epic.

a. Note: Remember, the estimated timeframe for an epic is about one month
for completion.

In the Target End field, select the estimated date the work on the epic should
be completed by.

In the Attachment field, add an attachment if applicable.

At the bottom of the screen, select the Create another issue checkbox.
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a. Note: In the future, if you are only creating one issue, checking this box is
not necessary.

17. Click the Create button.

You've successfully created an Epic in the Training Project!

You're going to create another Epic in the same project. If you selected the Create
another issue checkbox, you remain on the Create Issue screen. Repeat steps 8 -

16.

Continue to the next exercise to create stories.

Exercise 2 - Creating a Story
Estimated Time: 10 minutes

1. From the Projects drop-down list, select the View all projects option.

a. Note: The instance may prepopulate to the Projects screen as soon as
you select the Wireless Training option.

2. Select the Training project.
3. Atthe top of the screen, click the blue Create button.
a. The Create Issue screen displays.

4. In the Project drop-down field, ensure the Atlassian Training (JC101) option
prepopulates.

5. Inthe Issue Type field, select the Story option.

6. Inthe Summary field, input an appropriate summary for the work you’re
adding to the project.

7. In the Description field, input the applicable description for the Story.
8. In the Assignee field, select yourselffrom the drop-down list.
9. In the Sprint field, select the applicable Sprint for the story.

10. In the Story point estimate field, input the applicable numerical value
associated with the length of the work and its complexity.

11. In the Target Start field, enter the planned date for work to start on the Story.
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12. In the Target End field, select the estimated date the work on the epic should
be completed by.

13. In the Attachment field, add an attachment if applicable.
14. At the bottom of the screen, select the Create another issue checkbox.

a. Note: In the future, if you are only creating one issue, checking this box is
not necessary.

15. Click the Create button.
You’ve successfully created a Story in the Training Project!
You're going to create three more stories in the same project. If you selected the

Create another issue checkbox, you remain on the Create Issue screen. Repeat
steps 3 - 15.

Exercise 3 - Linking Issues
Estimated Time: 5 minutes

1. At the top of the main navigation bar, select the Your Work option.
2. Click the Go to your work page
3. Select one of the Stories you’ve previously created.

a. Note: These will have a green box next to their name. Epics have purple
box icons.

4. On the right side of the screen, select the Epic Link dropdown.

5. Search for and select one of the Epics you’ve created. Select the applicable
Epic to affiliate to this story.

6. The story now appears as a linked issue on the epic that you can click into.

7. Depending on your setting, the Epic might be is blocked by a story, meaning it
cannot be closed out until the story is closed out.

Congratulations on completing this lab!
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Exercise 4 - Performing a Basic Search
Estimated Time: 5 minutes

The next few exercises will lead to the creation of a Dashboard, starting with a
Basic Search of the issues you created.

1. Choose Search > View all issues. If the advanced search is shown instead of
basic, click Switch to basic. You can also reach this view by clicking Filters >
Advanced Issue Search.

2. Setyour search criteria by clicking the Assignee drop down.

a. Find your name in the Assignee list, then click it.

3. Click Search.

Exercise 5 - Creating and Saving a Filter
Estimated Time: 5 minutes

The next few exercises will lead to the creation of a Dashboard, starting with a
Basic Search of the issues you created.

1. Save the Basic Search you just created by clicking “Save as” next to the
Search header.

Type in a name for your Filter in the Filter Name field.
Once the filter is named, click the blue Submit button.
To share the filter, click the Details button next to Save As.

Click the Edit Permissions link.

o o A W N

Under the Viewers dropdown, select “My Organization.”
a. Click Add

b. Click the blue Save button.
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Exercise 6 - Performing a JQL Search

Estimated Time: 5 minutes

We will now perform a more advanced search using JQL. This will be done by

creating a JQL Query that finds all of the Issues you’ve created on the current

date.

1. Choose Search > View all issues. If the Basic search is shown instead of JQL,
click Switch to JQL. You can also reach this view by clicking Filters >
Advanced Issue Search.

2. Perform the following JQL Query:

a. Project =JC101 AND assignee = currentUser() AND createdDate = now()

3. Save this JQL Query as a Filter. Refer to Exercise 5 if you need a refresher.

Congratulations on completing this lab.
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Exercise 7 - Creating a Dashboard
Estimated Time: 5 minutes

Now we will create a Dashboard based off of your JQL Query.

1.

4.
5.

From the Navigation Bar, click Dashboards > Create Dashboard

a. The Create Dashboard Window displays

. In the Name field, enter an applicable name for your Dashboard.

a. Inthis case, simply write [YOUR NAME]'s Dashboard
In the Viewers field, select My Organization from the dropdown.
Click the Add button

Click the Save button.

Your Dashboard has now been created.

Exercise 8 - Adding a Dashboard Widget

Estimated Time: 10 minutes

1.

In your new Dashboard, click the Add Gadget button

a. Note: if you do not see the Add Gadget button, click the Edit button.

. A Column will pop up on the right side of the screen.

Add the Issue Statistics gadget by clicking the blue Add button.

a. Note: if you do not see the Issues Statistics gadget, search for it using the
Search tool at the top of the Gadget column.

In the Issue Statistics column, search for the JQL Filter you created in Exercise
6.

a. Then click the Save button.

Click the blue Done button.

1
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Exercise 9 - Creating an Advanced Roadmap
Estimated Time: 5 minutes

1. Select Plans > Create Plan from the Navigation Bar at the top of the page.
2. Enter the name of your Plan.
3. Under Issue Sources, add your Filter by selecting Filter from the Dropdown.
a. Then choose your Filter.
4. Click Add Another Source
a. Then add a Filter from another Team Member.
5. Repeat Step 4 a few times until you have a good range of Stories.

6. Click the blue Create button.

Exercise 10 - Adding a Dependency Between Stories
Estimated Time: 5 minutes

1. Select two stories you’d like to create a dependency between.
2. Hover over one of these stories so that a plus sign appears.
3. You can now add the Dependency one of two ways:
a. Method 1
i. Click the plus sign next to the story. Clicking the left plus sign will make
the story “is blocked by.” Clicking the right plus sign will make the story
the blocker.

ii. Selectthe effected story by clicking “Choose an Issue”, then click the
Checkmark.

b. Method 2

i. Drag the plus sign from one story to the other story. This will
automatically create the dependency.

ii. Note: This is an easy way to connect two stories if they are close to
each other on the Roadmap.
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Exercise 11 - Reviewing and Confirming Changes
Estimated Time: 5 minutes

Advanced Roadmap changes are not applied to issues unless they are reviewed
and saved.

1. Click the blue Review Changes button at the top right of the screen.

a. Note: the number next to the button indicates how many changes will be
made if they are saved.

2. In the Review changes module, click the blue Save selected changes in Jira
button to confirm the changes.

a. Note: You can deselect any changes you don’t want to apply by
unchecking them on the left side of the module.

Congratulations on completing the Lab.
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Exercise 12 - Space Permissions
Estimated Time: 5 minutes

To edit the permissions of a Space:

1.

Click the Space Settings tab on the left-hand side of Confluence. Then click
General under Space Permissions.

Click the Edit Permissions button at the bottom of the page.
Add a User to the Space by typing their name in, then clicking the Add button.

Select the permissions you’d like the User to have by clicking the check boxes
for each Permission Type.

Click the Save all button at the bottom of the page to save the permissions.
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Exercise 13 - Page Restrictions
Estimated Time: 5 minutes

To modify who can view and edit a Page:

1.

2.

Select the Page you wish to edit the permissions of.

Click the lock icon at the top right of the page.

The Restrictions dropdown module appears.

a. Note: Anyone can view and edit refers to the Permissions of the Space
itself. If a user does not have permissions in the Space, they will not be
able to modify the page, even if they are given access to it.

Select Anyone can view, only some can edit.

1. Type the name of a user you’d like to be able to edit.

2. Note: Similar to the note above, “Everyone can view” only applies to users
who have access to the Space, not everyone in Confluence.

Click the blue Apply button.
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Exercise 14 - Creating a Jira Issue in Confluence
Estimated Time: 5 minutes

1.

2.

Highlight text on your Confluence Page
Choose the Create Jira Issue button that appears above the highlighted text.

Enter the Project, Issue Type, and Description. Your highlighted text will
populate the Summary field automatically.

Click the Create button.
The issue will be created in Jira and added to your page. If your text is in a

table, you’ll have the option to create multiple issues using Text from the same
column.

Exercise 15 - Displaying Issues from a Project in Confluence
Estimated Time: 5 minutes

To display a series of Issues in Confluence:

1.

2.

Edit your Confluence Page

Select the Jira Macro, either by using /Jira in the editor, or choosing Insert »
Jira at the top of the Editor.

Type in the JQL Filter you previously created.

Click the Search button to populate the Macro.

Then click the Insert button.

a. Note: you can add single Jira Issues by pasting the link of the Jira Issue, or

by clicking the Insert Link (Ctrl+K) Macro at the top of the Page and typing
in the name of the Issue.
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Jira Access Request Form

Atlassian Training Space

Atlassian University
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JQL Cheatsheet

Constructing JQL Queries

(Cco
n

All JQL queries consist of a field, an operator, and one or more values or functions. Complex
queries can link JAQL together with keywords.

Simple

project

field operator value

Fields

Complex

project =

field operator

AND assignee

in

(currentuser())

keyword field

operator

function

Assignee Epic Link Resolved
A Field in JQL is a word that Affected Version Filter Sprint
represents a Jira field (or a custom ) .
field that has been defined in Jira). Attachments Fix Version Status
Comment Issue Key Summary
Component Labels Text
Created Last Viewed Time Spent
Creator Priority Voter
Description Project Watcher
Due Reporter Custom Field
Operators i
An Operator in JQL is one or more > <
symbols or words that compare the
value of a Field on its left with one == =
or more values or functions on its
right and returning the results. ~ [
in notin
is is not
was was not
was in was not in
changed
Functi :
u n Ctl o n s Time People Issue

A Function in JQL appears as a
word followed by parantheses,
which may contain one or more
explicit values or Jira fields.

A function performs a calculation on
either specific Jira data, or the
function’s content in parentheses,
then returns the results.

startOfDay/Week/Month/Year
startOfEnd/Week/Month/Year
lastLogin()

now()

currentLogin()
currentUser()

membersOf()

issueHistory()
openSprints()
watchedlssues()
myApproval()
myPending()

Example Query

created > startOfWeek() and assignee = currentUser() and (status = Open or (status = Reopened and priority in (High, Highest)))
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