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Appendix A: PowerView Tips

Here are some important concepts to remember as you use PowerView:

Selecting and Displaying Data Items

• Most data items are automatically marked Visible when you select 
them in the Select Session Data dialog box. If a data item does not 
appear in a display, check to make sure Visible has been toggled 
on.

You must also click Apply or OK in the Select Session Data dialog 
box before any item will display.

• To quickly turn data items on or off, click on Inventory in the task 
bar on the right-hand side of a window. A data tree appears, listing 
all categories and individual items you selected in the Select 
Session Data dialog box. Check in the appropriate boxes to 
deselect or select items. The display updates immediately.

If you have chosen a ZGF picture in the Select Session Data dialog 
box, the Inventory Task Pane will list the elements contained in 
that particular ZGF.

You can move the Inventory Task Pane to either side of or to the 
bottom of the window.

Make sure that whatever you toggle on or off in the Inventory 
Task Pane can be viewed in the current window. For instance, do 
not toggle off seismic from the Inventory Task Pane in a Well 
Correlation view.

• In Release 2003.19.1, PowerView introduced automatic selection 
of seismic Sections. Once your have chosen 2D lines or 3D 
surveys, you need only perform a few mouse clicks to make the 
seismic appear in Sections. Additional preliminary steps of 
selecting seismic volumes in the Select Session Data dialog box 
are not necessary.

• Beginning with R2003.19.1, current seismic priority determines 
which seismic appears in a Section. That is, when PowerView 
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finds the first seismic file to match the highest priority, the 
software displays that data item. To change the priority order of 
seismic files, open the Seismic Priority tab of the Contents dialog 
box (View > Seismic Priority Lists), highlight the file you want to 
have the highest priority, and press Move to Top.

• To see the seismic priority list of a 2D line, move your cursor over 
it. A tooltip appears with the information.

• If you are choosing data for one tab view, then move to another, the 
software will automatically switch you to the Select Session Data 
dialog box for the new tab view. This will be reflected in the 
titlebar of the Select Session Data dialog box. For instance, if you 
are selecting data for Map 1, then move to Section 2, the titlebar 
will change from Select Session Data (Map 1) to Select Session 
Data (Section 2).

To keep the dialog titlebar from updating, deselect 
Implicit Dialog Refocus in the View menu.

• In Release 2003.19.1, a new tab view, Well Correlation, became 
part of PowerView. By displaying wells and well data vertically 
and a fixed distance apart, the Well Correlation view lets you 
perform pick interpretation in an uncluttered but more detailed 
format.

• To open a new Map or Section while you are working in the 
bottom list of the Select Session Data dialog box, highlight the 
name of a horizon or seismic file. Then click on the New Tab icon 
above the list. The new tab will bear the name of the horizon or 
seismic file you highlighted, and the tab view will display the item. 
This procedures works with horizons and seismic files only.

• To drag and drop a tab directly onto the desktop, use the icon 
labeled Use Btn 1: Undock This Tab. It is located in the top right-
hand corner of the PowerView window.

• If you add seismic to an empty Section tab, it will not appear until 
you have chosen a Section. You can do this by

— using one of the icons in the Section Selector toolbar

— making a choice in the Section From List dialog box, 
available by selecting Select > Section from List... in the 
main menu or by clicking on the Section from List icon in 
the Section Selector toolbar.
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If seismic still does not appear in a Section:

— Make sure the Visible check for the seismic file is toggled 
on.

— Compare the domain listed in the main menu’s 
Select Domain text field with your seismic’s Domain 
column, shown in the bottom list of the Select Session Data 
dialog box. They may conflict. If so, use the Select Domain 
pulldown menu in the toolbar to change the domain of the 
Section and make it match the volume. Or, turn off the 
Domain Match toggle in the bottom list of the Select 
Session Data dialog box.

— Check that the Section you selected is within the red outline 
on the Map.

— In the Seismic tab of the Select Session Data dialog box, 
check the seismic extents of the file. If the Section lies 
outside the volume extents, no seismic will appear in the 
Section.

• When working with seismic files in the Display Order tab of the 
Contents dialog box, the software displays only one volume for a 
specific attribute per 3D project. For example, to overlay two 
volumes, both of which are Amplitude (Amp), you must define 
one as a different attribute (Other_1) and manipulate the seismic 
display template for those attributes individually.

• If Vip projects do not appear in the data tree of the Select Session 
Data dialog box, do as follows:

— Check to see that you have clicked on the Browse tab in the 
Select Session Data dialog box. Vip projects are listed in 
that data tree, not in the data tree of the Active tab. 

— If no projects appear in the Browse tab, make sure you have 
set the environmental variable VIP_DATA_HOME and  
specified the directory where Vip data is to be located. Even 
if you have set the environmental variable, Vip projects will 
not appear unless the variable points to the correct directory 
for Vip data.

• Three domains are available: Time (TWT), depth (TVDSS and 
TVD), and Frequency. TWT, TVDSS and FREQ are choices in 
the main toolbar. You can select TVD in the Select Display Datum 
dialog box (File > Display Datum). FREQ works with SpecD 
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data. A certain layer is processed at different frequencies, and you 
use the FREQ domain to show the data at different frequencies.

• PowerView has two dialog boxes in which you can “share” data 
items among active and “target” views. These dialog boxes are 
Contents; and Modes, Scale and Position. In the right side of these 
dialog boxes, a checkbox, selected by default, says, 
Only apply settings from this tab. If you want to share more than 
one kind of data with a view, be sure that this option is toggled off.

— “Sharing” dialog boxes have a Source view and one or more 
Target views. If you want a Target view to include data 
items in the Source view, push the Share Source button in 
the Contents or Modes, Scale and Position dialog boxes. If 
you want the Source view to share what is in a Target view, 
push Share Target.

— To designate a new Source view, place your cursor in the 
appropriate row and press Mouse Button 2. The row 
becomes gray, and the word Source appears in the Type 
column.

• To make a discontinuous multipanel display while you are in 
Point to Point mode, use the Button 3 popup menu available in a 
Map. Click MB1 to start a line, MB1 to end it, and MB3 to open 
the popup menu. Select Break. Repeat as many times as desired. 
Then, to display the multipanel, click MB2 or press MB3 and 
select Begin Display.

• Be sure to press <Return> when you enter data into the text fields 
of the Select Session Data dialog box and other lists. You must also 
press <Return> after you type in new weights when performing 
Math Blending in the Image Composer. The new value will not be 
accepted until you do.

• To change the histogram scaling value for the color bar, you can 
use the pulldown menu in the Hist. Scale column in a list of 
selected data items. Or, you can type in a number.

• To quickly change the opacity of a display, use the Opacity 
adjustor within the Parameters box at the bottom of a histogram. 
Click on the arrow next to the word Parameters to expand the box.

• To quickly reset the area-of-interest display for a survey, right-
click on the survey name in a list of selected session items and 
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choose Reset IL AOI, Reset XL AOI, or Reset Both. Then click 
Apply or OK.

• Only Math Blended composed images can be saved as horizons or 
used as input grids to create other composed images. 

• Do not use a GeoProbe shared volume in the Volume Composer.

• Do not use a Mouse Button 3 menu while you are running the Slide 
Show (Window > Slide Show...).

• You can use session files from Release 2003.19.1 in Release 
2003.19.2. Landmark recommends that you resave older session 
files after they have been successfully restored. Doing so will help 
ensure continued compatibility.

• After loading data and constructing your layout of tabs and 
windows, save a session file before you begin interpretation.

Color Display

• Most PowerView color bars are displayed with the maximum value 
at the top and the minimum value at the bottom. This design is the 
same as that for the SeisWorks Seismic View color bar. Only Time 
horizons in the Map will be displayed with the minimum value at 
the top and the maximum at the bottom, as in the SeisWorks Map 
View.

• The default color bars are different for horizons and seismic 
volumes. For horizons, the default is 0_Spectrum. For seismic, it 
is Greyscale.

• When you want to select a new color bar from File > Open in the 
Color Editor, you can choose from one of three lists: System, 
with a static list of palettes; GeoProbe, which contains the static 
palettes available in GeoProbe; and User, which consists of 
color bars that you have created. However, if you click on the 
Open a color palette icon in the Color Editor, you will see all 
color bars, including the ones you created.

• A shortcut to choosing a color bar is to right-click in the Color Bar 
task pane. Then click on Select Colors and choose from either 
System. GeoProbe, or User, as described directly above.
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Window and Tab Display Behavior

• To create an instant tab when working in a Map or Section, o click 
on the New Tab icon in the PowerView main toolbar. If you are 
working in a Map, the new tab will be a Map tab. If you are 
working in a Section, the new tab will be for a Section, and if you 
are in a Well Correlation view, the new view will be for a Well 
Correlation display.

• If you create a Map tab from another Map tab, the display in the 
original Map tab will be replicated in the new Map tab. The same 
principle applies to Sections and Well Correlation views.

• If you create a new Section tab from a Map tab, the new Section 
tab inherits properties from an existing Section tab. Likewise, a 
Map tab created from a Section tab takes on the properties of an 
existing Map tab. The tab from which a new tab inherits is always 
the most recently active tab of that type. 

If you create a new tab and one of the same category does not exist, 
the new tab takes on some of the properties of the source tab, while 
other properties will take on default values appropriate for the new 
tab type.

• You can rename a tab manually. To do so, click a tab name with 
Mouse Button 3. When the Tab Manager Menu appears, click on 
Rename. An Input message box appears. Type the new name in 
the text field and click OK.

You cannot rename a window.

• When you display a horizon or a seismic volume in a tab view, its 
name and a thumbnail of its associated color bar appear at the top 
of the color histogram in the window. If you display two or more 
data items, up and down arrows appear alongside the names. 
Clicking on the arrows show you the names of the other data items 
and their associated color bars. This functionality is not for 
animating through data items or changing the display order.

• Lock icons in the menubar apply only to actions you take in the 
Modes, Scale and Position (View > Modes, Scale and Position) 
dialog box. Clicking on the Unlock Modes, Scale and Position 
icon temporarily unlocks a tab view from other views. Clicking on 
the Relock Modes, Scale and Position icon relocks the view to 
the other views. A view that has been unlocked is indicated by the 
appearance of the Relock Modes, Scale and Position icon in 
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appropriate fields of the View Groups interface of the Modes, 
Scale and Position dialog box. 

• Preserve Aspect Ratio in the View menu is off by default for 
Sections and Well Correlation views. Once you are satisfied with 
your aspect ratio, toggle this option on.

• To make a cross-hair appear when you turn on the Point Marker, 
click on the box that says Display a cross-hair at the marker 
location. You find this option in View > Contents > View 
Properties tab > Marker tab. Then click Apply or OK.

The TransformView

• This tool lets you calculate attributes on the fly. As you work with 
it, you may want to resize the TransformView. Landmark 
recommends that you freeze it first. To do so, click on <F4>, and 
check the Resize button in the TransformView pane in the Task 
Pane. Then move your cursor up, down, and sideways within the 
Transform View to manipulate its size. 

The resizing operation ends when you take your finger off the 
mouse.

• Open the TransformView in a window with a single Section.

• You can zoom the display within the TransformView window. To 
do so, use the up or down arrows in the TV Window Zoom text 
field in the Task Pane.

Interpretation

• Beginning with 2003.19.1, you can interpret both 3D and 2D data.

• When you select an interpretation mode, the software displays a 
Task Pane with functionality for that interpretation mode. You can 
also access the panes by clicking on Interpretation in the Task 
Bar on the right-hand side of the window.

Horizons

• Multi-Volume Track in horizon interpretation lets you pick 
multiple horizons on multiple seismic volumes simultaneously or 
multiple horizons on a single seismic volume simultaneously. 
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Use the Wizard in the Horizon Interpretation pane of the Task 
Pane to complete a job. Then press Open Window to see the 
results.

When you work with Multi-Volume Track, start from a new 
session instead of a saved session.

• You can use the special autotracker ezTracker Plus for horizons in 
PowerView. The prefix or suffix “ezT” is attached to horizons 
autocreated in ezTracker Plus.

• If you want to clean up horizons in a Map, use Polygon Track. If 
you want to extend your interpretation in a Section, use 
Area Track. A red band in the Map designates the zone of your 
tracking. See the “Horizon Interpretation” chapter in the 
PowerView Guide for more information.

Faults

• Use the Convert to Segment option to interpret a triangulated 
fault quickly. With Mouse Button 3, click on or near the 
triangulated fault and select the conversion option from the 
resulting popup menu.

• A fault segment can have no more than 64 points.

• You use the ezValidator to align horizons across faults. You can 
unfault all horizons at once, and animate the unfaulting. If you 
enter an interpretation mode while you are using ezValidator, the 
ezValidator will automatically revert to View and cease its 
operation. To resume use of the ezValidator, toggle on one of the 
unfaulting options under View.

• Load a set of faults and faulted horizons before you enter 
ezValidator.

• In Release 2003.19.1, PowerView introduced a fault autotracker, 
which is called smartFault in Maps. 

This autotracker picks fault traces on horizontal time or depth 
slices. It works best with a special fault attribute volume generated 
from coherency data, but it can also pick faults directly from the 
coherency data. 
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For more information on smartFault, see the “Fault Interpretation” 
chapter in the PowerView Guide.

Well Picks

• You can interpret surface picks or faults picks in PowerView.

• Beginning with Release 2003.12.2, you create surface names under 
the Surfaces tab in the Create Interpretation Object dialog box. 
You can open this box from the Mouse Button 3 popup menu 
during well pick interpretation. Select Create Surfaces to do so. 
Or click on the Create Surfaces icon at the top of the Well Pick 
Interpretation Task Pane.

• You can use the Mouse Button 3 popup menu to remove wells 
from a display during well pick interpretation. Move your cursor 
near wells you want to remove, and click Mouse Button 3. The 
menu now includes the option Remove Well with the name of the 
well after it. Click on the well to remove it. To make it appear 
again, press Mouse Button 3 again and select Turn All Wells On.

• When you are in well pick interpretation, you can link all picks of 
the same name on a continuing surface. This process is called 
Auto-Regridding. For more information, see the “Well Pick 
Interpretation” chapter in the PowerView Guide.

Polygons/Centerlines

• Beginning with Release 2003.19.1, PowerView provides direct 
creation and interpretation of centerlines in a Map. Among the 
features of centerline interpretation is centerline clipping. Use this 
functionality when you are drawing a new centerline and cross 
another centerline. Then the centerline you are drawing will 
automatically be terminated where it meets the existing centerline.

• Beginning with Release 2003.12.2, you can work with both open 
and closed polygons.

• To quickly smooth polygons, use one of these methods:

— Click on a polygon, and select Smooth Polygons from the 
Button 3 popup menu

— In the Polygon Info section of the Task Pane, select one or 
more polygons from the list and click on the icon labeled 
Smooth selected polygons.
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• You can automatically generate polygons for a horizon that has 
been fully interpreted, interpolated, or processed using ezTracker 
Plus. To do so, use the Auto Poly panel in the Polygon 
Interpretation task pane.

• PowerView lets you extend the range of polygons by graphically 
joining them. For instructions, see the “Joining Polygons” section 
of the “Polygon Interpretation” chapter in the PowerView Guide.

2D Seismic Shift Management

Displaying Mistie Values

Mistie values appear in a Map only after you have made proper choices 
in the Display column of the Horizon tab in the Select Session Data or 
Contents dialog boxes. By default, Data Only is selected in the 
Display column; click in the text field of the desired horizon and select 
Mistie Only to see the mistie values without the horizon displayed. 
Select Data and Mistie to see the horizon and the mistie value at the 
same time. Press Apply or OK after making your selections.
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Appendix B: 
Gridding and Contouring Behavior

PowerView contains the following gridding and contouring algorithms:

• Refinement Gridding and B-Spline Gridding — These two 
 surface modeling algorithms are significantly faster than anything 
available in Z-MAP Plus. Since gridding speed may be increased 
by a factor of 10 or more, PowerView can construct models from 
larger data sets than ever before possible.

• Contouring — The contouring routine is faster than traditional 
algorithms and less prone to leaving color holes in maps. 
Contouring uses new display parameters, including fault 
annotations that conform to industry standards. Its combination of 
speed, multiple viewing windows, and the ability to 
simultaneously display surfaces from different sources has the 
potential to greatly enhance integrated data exploration.

All but a few settings in gridding and contouring have default values, so 
you can quickly generate grids and contour maps, then refine them with 
customized settings if you like.
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Refinement Gridding

The Refinement Gridding algorithm takes full advantage of the large 
memory on modern computers and incorporates several innovative 
ideas to speed up processing.

Refinement Gridding is the default gridding algorithm for Grid and 
Contour and is the gridding algorithm you use if you want to include 
faults in the grid. This algorithm also works well on unfaulted data and 
is particularly effective at producing a grid that optimizes the 
appearance of both regional trends and local detail.

Refinement Gridding conducts a series of refinements until the target 
grid cell size is reached, passing the surface model through a 
biharmonic filter to produce a minimum curvature surface (page 17).

The following example shows a grid generated with Refinement 
Gridding from data that includes complex faulting.

In the example, the surface model used for tracing the contours has 275 
rows and 450 columns. The input data has 42,000 seismic shot points 
and 6,000 fault segments. The model took only a few seconds to 
generate using Linux.
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Description of the Refinement Gridding Algorithm

Refinement Gridding starts with a coarse grid whose nodes are 
initialized with the average values of the input data. The grid is refined 
into a series of finer grids until the target grid cell size is reached.

At each refinement level, the surface model passes through a 
biharmonic filter, producing a minimum curvature surface. Each 
iteration ties the surface back to the actual data points, ensuring that the 
surface model closely honors the input data points.

Refinement Gridding’s iterative refine and filter approach results in a 
surface model that

• varies smoothly from point to point.

• extrapolates above or below actual data values.

• continues trends beyond the data into void areas.

Working at coarse spacing imposes the low spatial frequencies of the 
data on the surface, and working at finer spacing imposes the higher 
spatial frequencies of the data on the surface. Another way of saying 
this is that working at coarse spacing imposes the regional trends of the 
data on the surface while progressing to finer spacing generates a 
surface that closely honors the data.

Initial Grid Refine and Smooth Refine and Smooth
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Fault Processing in Refinement Gridding

Fault traces are supplied as input to the Refinement Gridding algorithm 
as a sequence of records, one for each fault vertex. Each record is 
assumed to have four fields: x, y, segment ID, and vertical separation. 
The vertical separation value may or may not exist. If vertical 
separation is a null value, the fault is opaque.

Each fault trace defines a single line fault or fault cutout, and is stored 
in working memory in a simple data structure with the coordinates of a 
bounding box, as shown in the following example. If the algorithm 
needs to know whether a 2D line crosses a fault trace (for example, a 
2D line that joins a data point and a grid node), the question is 
answered relatively efficiently because for most fault traces the line 
does not cross the bounding box. For this reason, the detailed problem 
of checking for crossing with individual fault segments is focused on a 
limited subset of fault traces.

The heavy line with markers at each end 
connects a data value to a grid node. Only one of 
the two fault traces must be checked to see 
whether it crosses this line because the line 
crosses only one of the bounding boxes around 
the fault traces.
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Fault Blocks in Refinement Gridding

As a grid is refined, the nodes in newly revealed fault blocks must be 
initialized before they can be smoothed. A potential problem with most 
surface modeling paradigms is that small fault blocks are not 
represented at some of the coarser grid spacings.

To solve this problem, Refinement Gridding uses a fast bleed of data 
from already filled nodes through open ends of fault blocks. If fault 
blocks are closed, the algorithm simply ignores opaque fault barriers to 
pick up values from nodes in normally off-limits neighboring fault 
blocks.

The following example shows the usefulness of the fault block fill-in 
process with a highly faulted well data set. Many of the smaller fault 
blocks contain only one or two wells, and others have no wells.
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B-Spline Gridding

The B-Spline Gridding algorithm is a very fast algorithm for generating 
unfaulted surface models from scattered data.

Description of the B-Spline Gridding Algorithm

B-Spline Gridding creates a series of increasingly fine control lattices 
to generate a sequence of bicubic B-Spline functions whose sum 
approaches the target interpolation function. B-Spline Gridding is fast, 
making it ideal for gridding large datasets that have no faults included 
or that have one million or more data points.

As in Refinement Gridding, working at the initially coarse spacing 
imposes the regional trends of the data on the surface while progressing 
to a finer spacing generates a surface that closely honors the data.

The B-Spline Gridding algorithm produces a surface model that closely 
honors the original control points, varies smoothly from point to point, 
and continues trends beyond the data into void areas.

The B-Spline algorithm starts by enclosing all data points in a single 
cell and extrapolating nodes for eight surrounding cells, as shown in the 
following example. The 16 grid nodes that result are initialized to an 
average value of all data points.

In this example, a dataset of 10 
points is enclosed in a single grid 
cell, and eight surrounding grid cells 
are extrapolated.

All 16 nodes are initialized to the 
average values of the 10 data points.



Landmark PowerView Tips and Resources

2003.19.2 Appendix B: Gridding and Contouring Behavior 21

A bicubic B-Spline function is fit to each data point, based on input 
from the control point itself and the 16 surrounding nodes. To make the 
function fit the control point exactly, the 16 node values are adjusted up 
or down from their initial value. A cross-section view of this 
adjustment is shown in the following illustration.

When the process is finished, each grid node has a new value based on 
every data point. For example, if the dataset contains 10 data points, a 
new value for each node is computed 10 times. The 10 values are 
averaged to produce the final node value for the current refinement 
pass.

The grid is refined by using cubic B-Spline interpolation, and the 
process is repeated. As shown in the following illustrations, after one 
refinement the area occupied by the data points is divided into four 
cells. After a second refinement the area occupied by the data points is 
divided into 16 cells. (The grid contains 16 cells that could potentially 
contain one or more data points.)

After each refinement, the bicubic B-Spline curve is fit through each 
data point again, using an equation based on the value of each point and 
its new set of 16 surrounding nodes. The curve fits the data point, and 
the node values are adjusted. The process continues until the grid 
reaches the target cell size.

A bicubic B-Spline curve is 
fit through each data point, 
forcing the values for the 
16 surrounding nodes to 
be adjusted up or down.

After first refinement After second refinement
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Contouring

The Contouring algorithm uses the Cell Priority contouring approach. 
This approach is not new, but until recently, the limitations of computer 
memory made it impractical. In Cell Priority contouring, the following 
events occur:

1. A smooth surface model is developed from a grid cell, based on 
interpolated grid nodes surrounding the grid cell.

2. A refined grid is superimposed on the cell.

3. Z-values for the new nodes are interpolated.

4. Contour segments for the cell are generated from the model.

Each grid cell is processed in sequence, then the segments are retrieved 
from storage and assembled into complete contours. Ultimately, the 
smoothness of the contours is controlled by how densely the grid cells 
are refined.

The Refinement parameter controls the number of points needed to 
represent a contour. The coarser the refinement, the more angular the 
contours, as fewer points are used to represent the lines. The finer the 
refinement, the smoother the contours, as more points are used to 
represent the lines. You can use any of five refinement options, ranging 
from Very Coarse to Very Fine.

At the Very Coarse setting, no refinement is performed.

104.3

96.1 128.4

71.9

100

Using linear interpolation, the algorithm finds the 
point at which a contour segment crosses a cell 
boundary between the two Z values at the nodes 
marking the ends of the cell edge.

The program locates the entrance and exit points—
the points at which the contour segment enters and 
exits the cell. The contour segment is treated as a 
straight line between these two points.
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The coarsest refinement is very fast, but results in linear contours with a 
faceted look. Contours are not smooth, and any auxiliary data that 
exists is ignored.

A step up from the Coarsest (linear) method uses a refined grid cell. To 
refine each grid cell, the application uses additional nodes (for a total of 
16 grid nodes) around the grid cell. The data from the additional nodes 
is used to create a smooth model.

Sixteen Nodes Used to Create a Surface Model for a Grid Cell

Linear interpolation is then applied to each cell in the refined grid.

Effect of Refinement Levels on a Contour: Detailed View

At Coarse refinement, the 
cell is refined by a factor of 2. 

At Fine refinement, the cell is 
refined by a factor of 8. (For 
Very Fine, the refinement 
factor is 16.)

At Medium refinement, the 
cell is refined by a factor of 4.



Landmark PowerView Tips and Resources

2003.19.2 Appendix B: Gridding and Contouring Behavior 24

The following examples show contours becoming smoother at a higher 
refinement level.

As refinement changes from Coarse to Very Fine, contours appear less 
angular and increasingly smooth.

Effect of Refinement Levels on a Contour: Map View

Coarse

Medium

Very Fine



Landmark PowerView Tips and Resources

2003.19.2 Appendix B: Gridding and Contouring Behavior 25

Effect of Refinement Levels on Number of Grid Cells

Once all the individual cells are processed and complete closed 
contours are assembled, the program uses line generalization to 
eliminate unnecessary points.

104.3

96.1 128.4

71.9

At Coarsest refinement, no additional 
grid nodes are interpolated.

At Coarse refinement, the single grid 
cell is interpolated into a 2 x 2 cell.

At Medium refinement, the grid 
cell is interpolated into a 4 x 4 cell.

At Fine,  
8 x 8 cell.

At Very Fine,  
16 x 16 cell.
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Appendix C: Working with Large Projects

When you work with large projects, you may wish to consider some of 
the following scenarios to improve overall workflow performance or 
stability. 

General Considerations

• On 32 bit architecture, the default jvm size is 1200m. In some 
circumstances, this size may not be large enough. If the 
Used Memory gauge remains in a high position, or the applications 
fail with “Insufficient Memory” messages in the run directory .log 
file, increase the memory by setting the following variable:

setenv POWERVIEW_MEMORY 1700m

If the environmental variable is set too high on a 32 bit machine, 
PowerView does not start because the java virtual machine (jvm) 
cannot be initiated. The maximum may vary by machine, but it is 
normally between 2000m and 1200m.

• If possible, use 64 bit architecture Linux machines for larger 
projects. PowerView is 64 bit enabled here and can manage more 
information in memory. The default jvm size for 64 bit is about 
5GB.

• You may also have to adjust the memory size for ezTracker Plus. 
Current defaults are 1200m for 32 bit systems and 2500m for 64 
bit systems. To increase these sizes, use the following 
environmental variable:

setenv PVEZT_JAVAXMX 2600

Running ezTracker Plus

• The default checkpoint interval—that is, when the tracked data is 
saved to disk—is now every 500,000 traces. On large surveys, this 
default may affect the tracking performance by writing and 
checkpointing too often. For example, a 40m trace survey may 
checkpoint 80 times. Before starting the ezTracker Plus job for the 

The Used Memory 
gauge is located 
in the status bar in 
the extreme 
bottom right 
corner of each 
PowerView 
window. As you use 
memory, the red 
shown in the  
example here 
increases. When 
you see mostly red 
in the gauge, you 
are running out of 
memory.

The Used 
Memory 
gauge
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first time, use Ctrl + Mouse Button 1 on the Run ezTracker Plus 
button. When the ezTracker Plus Run Options dialog box appears, 
adjust the parameters.

• When you are tracking a strong event without faults—like the 
water bottom—you can reduce both initial and final tile sizes to 
three. This strategy will force one iteration and minimize the loop 
tie requirements. You may also see a slight improvement in 
performance if you use the Cross Correlation or Peak to Peak 
tracking methods in the Advanced tab of ezTracker Plus. Tests 
have shown improved tracking results from Cross Correlation 
when compared to Peak to Peak. 

For more information about ezTracker Plus, see the “Horizon 
Interpretation” chapter in the PowerView Guide.

Working with Multiple Projects

• When possible, use the Inventory Task Pane to deactivate 2D line 
lists or 3D surveys you are not working with. This strategy reduces 
Map clutter with one click and makes views update or zoom faster. 
3D project outlines are still displayed by default for ease of 
reference, but they do not affect display performance.

• When you work in a 3D project with many 2D lines, the 2D line 
intersections can affect the display performance of horizons in 
Sections. When you no longer need this display for reference 
during interpretation, turn it off by deselecting the 
2D Intersections box in the Section Intersections panel 
under the HorizonSection tab of the Contents dialog box 
(View > View Properties > HorizonSection tab).

• Set the seismic priority in View > Seismic Priority List... for each 
3D and 2D project. Seismic is then automatically selected in the 
next new session, and you save time when many projects exist.

• Use the Set/Clear AOI icon on the Map to keep the Map focused 
on the current area of interest. You can still temporarily zoom out 
with the isotropic zoom.
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In the Section

Working Within a Reduced Area

By default, PowerView displays the entire line, including the entire 
time/depth range for a Section. If possible, reduce the area for the large 
3D surveys that you work with at any one time. To do so:

— Use the Select Z Range By Domain dialog box to manually 
set the desired Section z range (Select > Z Ranges...). 

— In the 2D/3D Projects tab at the bottom of the 
Select Session Data dialog box, click Mouse Button 3 
within one of the AOI inline or xline columns for a 3D 
project. When a pulldown menu appears, choose 
Select IL/XL AOI From Map. In the Map, hold down 
Mouse Button 1 and drag it until you have selected the 
desired working area. When you release the button, the 
ranges change in the appropriate AOI line columns. The 
software then restricts seismic Sections and Map horizons 
to the range.

Caching One Full Inline or XLine

• It is important that a full Section (inline or crossline) be held in 
cache. The default seismic cache sizes are 40:40:25 for brick files 
(.bri); uncompressed cache (.cmp); and compressed (.cmp). 
Compute the required sizes, then set the following environmental 
variable:

setenv LGC_PV_SEISCACHE_MAX 50:50:40

In general, you should stay below 100:100:75. If this size is not 
large enough, you may want to consider turning off the seismic 
read-ahead in the SeismicCache tab in the View Properties tab of 
the Contents dialog box. Otherwise, the read-ahead may compete 
with the Section reads.

Special Note: More cache does not always mean faster 
performance. It is important to find the right number based on 
experience with the project and the network environment.

Populating the Local Disk Cache

• If you have a large amount of free local disk, cache the 
primary volume by using the Cache Manager under  
View > View Properties > SeismicCache tab. Here you can 
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cache all lines, crosslines, or a specific increment to disk. 
If you use an increment, set the line selection to the same 
frequency. Then normal selections will always find a line in your 
cache.

In general, disk-cached lines and crosslines display in about one 
second, regardless of the size. If you find this strategy useful and 
want it activated by default for new sessions, set the 
PV_USE_LDISC to “ro” (read only) or “updated” (read-write). 
For best performance, you may want to pre-populate the cache and 
use the read-only option. 

For more details, see “Seismic Caching” in the “Setting 
Properties” chapter of the PowerView Guide.

Well Curves, Especially with Colored Fill

• If you do not need curves turned on in the Section all the time, use 
the Inventory Task Pane to temporarily turn them off. Click on 
the main Log Curves branch to do so.

Horizon Data

Local Temporary Cache

• Horizon data displayed in the system may be cached to a local 
disk. This disk should have enough space to hold horizons of the 
size and number that you will be working with at one time. If the 
available space is insufficient, the system will revert to rereading 
horizons from the remote project drive. This process can be slow.

• By default, this disk location will be the system tmp directory. You 
can control this location with the following environmental 
variable:

setenv LGC_HZN_TMPDIR <local drive/directory 
with lots of space>

• You can also set the limit of disk space that will be used. The 
system will validate your disk with sufficient space for the request 
and will not allow the request to exceed 90 percent of the free 
space. This size is in MB. The environmental variable is

setenv PV_HZN_MAXTMP 5000
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Note: If, when running PowerView, it fails with a native code 
exception, this local disk cache directory may not be properly 
cleaned by the exit handler. It is a good idea to check the location 
occasionally to ensure no older files remain. Delete any that you 
find.
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