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App Outline 

 

 

Project Management Express is a project management application that allows project 

managers to view the details of their assigned projects easily. As well as the start and end 

dates, project Management Express displays the project type, such as fixed price or time 

and material, and the status of the project, such as “not started”, “ongoing”, or “completed”. 

Project Managers can also log their work hours, submit Timesheets, and see their total hours 

allotted to complete the project. They can also view any remaining hours as well as their 

current hours worked for a particular project. Additionally, there is a field for invoicing that 

shows whether a Timesheet has been invoiced or not. PM Express is a quick and easy-to-use 

application that can help your team stay on track. It can help you minimize payroll by 

accurately managing time and compensation. 
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Create Objects and Fields 

Search Schema Builder in Quick Find 

 

Click Clear all 

Go to Elements tab -> Create a new object -> label it Project 

 

Allow Reports and Activities -> Click Save 
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Next add a Master – Detail relationship to the account so that every project will be associated with 

an account 

 

Fill Account Name -> Related to Accounts (child relationship auto populates to Project) -> Save 
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Next create a Date Field -> Drag and drop Date field into the schema builder  

 

Field Label should be End Date -> click Save 

Next Create the Timesheet Object by selecting Formula, this will link to a Timesheet report for the 

given project. 

Drag and Drop Formula into the Schema Builder 
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Insert your formula -> select Text for Return Type -> Click Save 

 

Next field is the Opportunity. We want to link our Projects to opportunities. Select Lookup field and 

drag into schema. 
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Fill in Opportunity and Relate to Opportunity -> Click Save 

 

Now add the Project description. Select Text and drag and drop into schema 

Fill in Project Description as feild Label and make it 255 Characters -> Click save 
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Now create project status which will be a Picklist. Drag and drop Picklist into the schema builder 

 

Make Field Label Project Status and for Values you will have “Not Started”, “Ongoing”, and 

“Complete”. 
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Create a Project Type by dragging and dropping Picklist into Schema Builder -> Insert values 

necessary for your org and Save 

 

Start Date is a Date Field so drag and drop int schema builder Fill in Start Date and click Save 

Total Hours is a number Field so drag and drop Number into schema builder   

Make it a length of 16 with 2 decimals -> Click Save 
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Create a new Object  

Label it Timesheet-> Change Record name to Timesheet Number -> Set Data Type as Auto Number 

-> Allow Reports, Allow Activities -> Set Display Format to {YYYY}-{0} -> Click Save 

 

Now Create a Lookup field by dragging and dropping Lookup Field into the new Object  

Label it Consultant and relate it to the User Table -> Click Save 

 

Now to denote whether a particular timesheet line item has been invoiced create a checkbox field. 

Drag and drop Checkbox into the new object field -> Label it Invoiced -> leave it Unchecked -> 

Click Save 
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Now we want to relate it to the Project Object. Create a Master Detail Relationship by dragging and 

dropping into the new Object -> Label It Project Name and Project which will auto populate the 

parent child relationship to Timesheets -> Click Save 
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Now we want to add a date field to track what day the Timesheet was written for Label it Task Date 

 

We want to add a Description field to describe what kind of work we have done. Add a Text Area -> 

label it Task Description -> Click Save  
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Lastly total Hours for a given line item is going to be a Number 

 

Now for our Project Object we want to create an Hours Worked to date roll-up summary field. Drag 

and Drop Roll-up Summary field into Project -> Label it Hours Worked To Date -> Use timesheet 

Object in Summarized Object -> SUM for Summary Type -> Total Hours for Field to Aggregate 
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Lastly we need a Formula for Remaining hours which will be Remaining Hours -> Return type 

Number -> 2 decimal places -> Formula is Total_Hours__c - Hours_Worked_To_Date__c -> Click 

Save. 

 

The Schema Is done now we edit our layout. 
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Edit Object Page Layout 

 

From the project Object -> Click the Drop down and go to Object -> Click Page Layouts -> Project 

layouts  

 

In Project Layout move elements around to your liking -> Add Project Description under Project 

Detail -> Add Opportunity under Project Detail. 

Add a Section, label it “Detail” leave everything else default, add Project type, Start Date & End 

Date and Project Status. 

Drop in another Section call it “Hours”, inside of hours we want to add Total Hours, Hours Worked 

To Date and Remaining Hours. 

Drop in another section call it “Invoicing”, add Timesheets from last month. 

Under Related Lists add Timesheets and Click Save. 
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Now edit your related lists to include more relevant information for Timesheets by clicking the 

wrench icon 

 

Add Task Date as the First Column , Task Description as second Column, Total hours as third 

column, Whether its been invoiced and Timesheet Number 

Default in descending order 

 

Next Make Opportunity a required Field -> Click on wrench icon near Opportunity  -> Select 

Required 
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Click Save 

Go back to Object Manager and go to Timesheet Object -> Click Page Layouts 

 

Remove Timesheet Number -> Add Project Name, Consultant, Task Date, Task Description, Total 

Hours, and Invoiced -> Click Save 
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Now lets work on the report that will display the timesheet line items 
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Create A Report Type 

Go to Quick find and type in Report Types 

Click New Report Types 

Primary Objects will be Accounts, Report Type Labe will Be Projects and Timesheets, Description is 

Custom report type to access the project and timesheet fields, Store in category will be Accounts 

and Contacts Group, Mark it as Deployed. -> Click Next 

 

Next Account will relate to Projects, and the Projects will relate to the timesheets. 

Projects will Report on any account which has projects so select the first radio button. Select the 

second radio button under Timesheets to report whether the are timesheets or not. -> Click Save 
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Create A Report 

 Go to Sales App and Select New Report -> Lick Account and Contacts -> Projects and Timesheets 

 

Under Columns on the left panel remove Account Name and Timesheet Number, add Consultant 

Name, Add Task Description and Timesheet total hours. Next Group Columns by Task Date 

 

Now go to Filters and Show All Accounts, Created Date Show All Time, Project ID equals “” (a blank 

value), add Task Date Relative date “Last Month”-> Apply -> Save as Timesheet for Last Month  
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Make Public so anyone can access it -> Click Save 
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Sharing Settings 

 

Go to setup and type Sharing Settings in Quick Find Box 

Make sure Account object sharing setting is set to “Public/Read/Write” 

 

Next, check Project and Timesheet object and make sure it is set to “Controlled by Parent”  
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Now let’s create our Tabs so we can access our objects  

Search tabs in quick find and select  

Under Custom objects Tabs select Create New  

 

Select Project as object and give it a tab style of your choosing -> Click Next 
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Default on for all profiles -> Click Next 

 

Include in All apps -> Click Save 
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Do the same for the Timesheet object 

 

Next lets create an App to tie it all together 
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Create a Lightning App 

Go to the App Manager -> New Lightning App 

 

Label the app Project management and customize the Apps Branding if you like -> Click Next 

 

Leave everything as is -> Click Next 
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Click Next we don’t want any utility items 

 

Under Navigation items search Project, Timesheets and Reports and add them to your selected 

items -> Click Next 



P a g e  | 28 

 

 

Under User Profiles grant access to your specified Users -> Click Save & Finish 

 

Now you have a New App in salesforce called Project Management 



P a g e  | 29 

 

 

Lastly, we need to modify our formula for Last Months timesheet  

Go to reports in your Project Management App and click on “Timesheets for Last Month” Report 

 

Click on the address bar and select the Report ID, copy the Report ID 

 

Next, click on Projects and then the gear icon and select edit Object -> Fields and Relationships -> 

Timesheet for Last Month-> Go to Formula Field and replace “//*Report ID Here*//” with the 

Report ID you copied. 
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Click Save 

Now let’s create a custom email template to send when an opportunity stage changes 
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Create Custom Email Template 

Go to Setup -> Type in quick find Email templates -> Select Classic and New Email Template -> 

Select text and click Next 

 

Now select Project Fields under Field Type ->  Select Project Status -> Click the checkbox 

Available For Use -> Add Email template Name, Subject and fill in the Email body -> Save 
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Next we need to Create a validation Rule to trigger the email alert 
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Validation Rules 

Go to Setup and then Object Manager -> select the Project Object and select Validation Rules in 

side panel-> Click new 

 

Fill in the Rule name -> check Active and insert your formula  

AND(ISCHANGED( Project_Status__c ), 

OR ( ISPICKVAL(PRIORVALUE ( Project_Status__c ), "Ongoing"), 

ISPICKVAL (PRIORVALUE (Project_Status__c ), "Completed"))) 

Next add an error message and click Save 

 

 

Next we need to set up an Email Workflow Rule to send the Email when the Status changes 
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Workflow Rules & Email Notification 

Go to setup-> Search for Workflow Rules -> Continue -> Click New 

 

  

Select the Project object -> click Next -> Rule Name will be “Send Email when Project Status 

Changes” -> Fill in your description -> Select “created, and any time it's edited to subsequently 

meet criteria” -> Select “Run this Rule if the Criteria Are Met” -> Fill in criteria shown below and 

click Save & Next  
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Now Add a Workflow action-> Click New Email Alert -> Fill out description field and Select your 

email template that you created -> Select Users and enter any additional email addresses you need 

up to 5 -> Click Save & Done 
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Import Data 

Navigate to Setup and type Data Import into search box. 

 

 

Click on data Import Wizard scroll and click Launch wizard. 

 

Click on Custom Objects, Select the object  



P a g e  | 39 

 

 

You will be asked if you are updating existing records, adding new records or updating and 

adding new records. Select whichever option applies.  

 

Adjust options to fit your needs and select the CSV file you wish to upload. Drag & Drop or 

upload by searching on your computer. 
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Upload and make sure all data Maps to the correct Field.  

 

Click Next and Start Import 
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View  your completed import 
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Create a Profile in Salesforce 

 

Click the gear icon and click Setup 

Type Profiles in Quick find and click Profiles 

 

Click Create New Profile 

 

Click a profile to clone from 
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Enter a Profile Name and click Save 

 

 

You can edit Permissions and Layouts. 

Create a Profile for Social media Manager and one for Social Media Strategist 
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Create a User 

 

Click on gear icon and go to Setup. 

 

Once in setup search User in quick find box.  

 

Click Users to see current Users  
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Click New User and fill out General Information. All fields marked with red are mandatory. Be 

sure to click in User License and select the correct license for the specified role of the user in 

the organization.  

 

 

Scroll to complete Mailing Address, Single Sign on Information, Locale settings and 

Approver Settings.   
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Be sure to click the box to “Generate New Password Automatically” if you are adding a New 

User to the organization who needs to be able to sign in and click Save to save your new user 

profile. 
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To Deactivate a User click on edit and uncheck the Active box and click Save to make the user 

inactive.  
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Create List View Customizations 

 

Go to Leads tab in your org and click on the gear icon and select New 

 

 

Select New. 

Enter a new name in the List Name field. 

The List API Name is auto generated. 

Select who should be able to see this list. 

Click Save. 
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Click the List View Controls icon. 

Click Select Fields to Display. 

Move 1 or 2 fields from the Visible Fields to the Available Fields. 

Click Save and notice that the fields you removed are no longer visible in this list. 
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Create a Timesheet Screen Flow 

In Setup type Flows into quick find box -> Select Flows and Create a New Flow 

 

Select Screen Flow -> Click Next 

Click the drop –down and select Free Form -> Drag Screen from the side panel into the window 
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Fill in Screen properties -> Label is Enter Timesheet Detail, be sure to add a description 

 

Next Drag and drop Text from the components panel into the Flow Label area -> Fill out Label as 

Task Description -> check the Required box  
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Drag and drop Date into the screen -> Label Timesheet Date -> Make it required 

 

Next will be a Number so click number and add it to the screen -> Label it Hours Worked -> 

make it Required and add 2 decimal places  
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Click Done 

Now let’s work on our Drop down menu 

Go to Manager in side panel -> Click New Resource -> under Resource Type Select Record 

Choice Set -> Under API type Projects -> Description should be “List of projects in ‘Ongoing’ 

Status ->the object will be Project 
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Under Filter field select project status -> equals -> Ongoing -> sort list in ascending order by 

project name -> leave max number of choice blank -> choice label pull list of project names -> 

Data type is text -> Choice value is record ID -> Store Record ID -> variable click on Flow 

Global and select Current Record -> Click done 
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Now click New resource again -> Record Choice Set -> API Name Users -> Description “Pull all 

active users with company” -> User Object -> under Filters select isActive – Equals – 

GlobalConstantTrue -> add a condition -> Company Name – equals – ‘your company name’ -> 
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Sort in Ascending order -> by Name (Full Name) -> leave Max choices blank -> Choose label 

Name (Full Name) -> Type Text -> Choice Value User ID -> Store User id -> Variable click 

Global variable and select Current Record -> Done 
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Double the screen-> Add Picklist above task Description field -> Label it Projects -> Data Type 

is Text -> no Default value -> Choice is Projects -> Done 

 

Add another Picklist add under Projects field -> Label it Consultant -> Data Type is Text -> no 

Default value -> Choice is Users -> Done 
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Click Save -> Label it Timesheet Flow -> Description ‘Timesheet flow that prompts details and 

creates timesheet’- > Click Save 

 

Now you need to connect the screen flow to activate it. Select the circle under Start and connect 

it to the circle on Screen and click Save. 
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Click Run to see what you have in the fields  

 

Now lets create a Record  

Go to Elements on the toolbar and select Create A Record-> Label it Create Timesheet record -

> Description ‘Creates timesheet from screen data’ -> How Many records Only One -> How do 

we want to set the Fields, Use separate resources, and literal values. Object is Timesheet -> 

Field one is Consultant Value is Consultant Picklist -> Add a field -> Project Name, Value Project 

Picklist -> Add a Field, Task Date Value is Timesheet Date -> Add a Field, Task description and 

Value is Task Description -> Add a Field Total Hours and value is Hours Worked -> Click Done 



P a g e  | 62 
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Now let’s connect them. Drag the circle from the Screen element to the circle on the Create 

records element  
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Last Component is another screen component which will be the confirmation that the timesheet 

was created. 

Drag and drop a Screen component into the window -> Add Display text -> Label it 

TimesheetCreated -> Add the message “Timesheet Has Been Created!” 

 

Under Screen Properties label it Timesheet Created and hide the Header -> Select Navigation 

and Hide Previous and Hide Pause -> Click Done 

 

Click Done 

Link the Create Records to Timesheet Created and Run to test it out 
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P a g e  | 66 

 

  

 

Access your project management app to see if the record was created 

 

Now we want to add our timesheet record onto the homepage of our sales app. You need to 

activate your flow.  

Go to Setup and type in Flows -> select your Timesheet Flow and select activate  

 

Now go to your Sales app -> click the gear icon and select Edit Page -> Add Flow above 

Assistant  



P a g e  | 67 

 

 

Select Timesheet Flow under Flow in right panel -> Click Save -> Activate > Assign as Org 

Default -> Save 
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Go back to your homepage and you should see your Flow 

 

 

Congrats! You have a fully functioning Project Management App! 

 


